2021-05-27 04:36:46 +0200 <a6a45081-2b83> *an hour
2021-05-27 04:37:05 +0200 <a6a45081-2b83> can i make it so that it updates after internet or xmonad start after internet or any other soluiton?
2021-05-27 04:37:15 +0200td_(~td@94.134.91.198) (Ping timeout: 272 seconds)
2021-05-27 04:37:25 +0200 <jrgiacone> you might be able to use the sleep command
2021-05-27 04:37:39 +0200 <jrgiacone> to make iit wait and reload xmonad after a couple seconds
2021-05-27 04:38:30 +0200td_(~td@94.134.91.249)
2021-05-27 04:39:19 +0200 <jrgiacone> burp did you ever have any issues with xmonad displaying degree symbols? when I try to launch it with the default config i get hGetContents: invalid arguments (invalid byte sequence)
2021-05-27 04:39:26 +0200 <jrgiacone> sorry xmobar
2021-05-27 04:39:45 +0200 <jrgiacone> i have the fonts installed
2021-05-27 04:41:03 +0200 <a6a45081-2b83> you have to use \x2368 something like this
2021-05-27 04:41:06 +0200 <a6a45081-2b83> not the unicode symbol
2021-05-27 04:41:11 +0200 <a6a45081-2b83> the file has to be utf-8 afaik
2021-05-27 04:41:14 +0200 <a6a45081-2b83> i faced this issue
2021-05-27 04:42:05 +0200 <a6a45081-2b83> ignore- I have this in config and it works: <fc=#458588><tempC></fc>°C <fc=#458588><rh>% rh</fc>
2021-05-27 04:42:19 +0200 <jrgiacone> damn what the heck
2021-05-27 04:42:32 +0200 <jrgiacone> this was the issue I was running into the other day after building from source
2021-05-27 04:42:56 +0200 <jrgiacone> i have the utf8 and xft flags
2021-05-27 04:43:06 +0200 <a6a45081-2b83> I think I changed LC_ALL or locale to include ISO-8661 or something
2021-05-27 04:43:32 +0200 <jrgiacone> hmm how do you do that
2021-05-27 04:43:41 +0200 <jrgiacone> like my locale where i defined LANG
2021-05-27 04:44:49 +0200 <a6a45081-2b83> check this out https://github.com/koalaman/shellcheck/issues/324
2021-05-27 04:45:22 +0200 <a6a45081-2b83> my file was iso-8859-1 but my locale was LANG=en_IN.UTF-8
2021-05-27 04:45:31 +0200 <a6a45081-2b83> you have to edit a locale file and run locale-gen
2021-05-27 04:45:57 +0200 <a6a45081-2b83> so probably just try changing file type
2021-05-27 04:46:07 +0200 <jrgiacone> I'll take a look I know i use en_US.UTF-8
2021-05-27 04:46:15 +0200 <a6a45081-2b83> if you want to change locale check this https://wiki.archlinux.org/title/Locale#Generating_locales
2021-05-27 04:46:29 +0200 <a6a45081-2b83> but since it's working for me in UTF-8 probably better to change file type
2021-05-27 04:51:27 +0200 <jrgiacone> uncomenting en_US ISO-8859 got it to start thank you, now I have UnmarshalErrors when trying to read message headers lol
2021-05-27 04:52:06 +0200 <jrgiacone> actually reading message from socket might be because I am in a vm, not sure
2021-05-27 04:53:48 +0200 <jrgiacone> nvm didnt work lol
2021-05-27 04:56:43 +0200 <jrgiacone> interesting xmobar will only read when it is a root
2021-05-27 04:56:45 +0200 <jrgiacone> wtf
2021-05-27 04:57:42 +0200 <jrgiacone> nvm because it doesnt read the config, disregaurd
2021-05-27 05:00:10 +0200 <burp> hmm yea, it should work with with_utf8 and if the xmobar config is also utf8 encoded
2021-05-27 05:01:14 +0200 <burp> <a6a45081-2b83> can i make it so that it updates after internet or xmonad start after internet or any other soluiton?
2021-05-27 05:01:18 +0200 <burp> right, I thought about that too
2021-05-27 05:01:32 +0200 <burp> would be nice to trigger an update, like a weather update after hibernation
2021-05-27 05:01:43 +0200 <burp> an option is always to kill and restart after that, but it feels hacky
2021-05-27 05:01:59 +0200 <burp> wonder if xmobar has a kill signal that triggers an update
2021-05-27 05:02:54 +0200 <a6a45081-2b83> burp: still seraching for the same
2021-05-27 05:03:01 +0200 <jrgiacone> yea I still cant get xmobar to read the file even after running :w ++enc=utf-8 in vim
2021-05-27 05:03:01 +0200 <burp> file xmobar.hs should tell you if the file is utf-8 encoded
2021-05-27 05:03:17 +0200 <jrgiacone> im just trying to get xmobar to run on its own through terminal
2021-05-27 05:03:39 +0200 <a6a45081-2b83> try running `file` command on config file
2021-05-27 05:04:24 +0200 <jrgiacone> Unicode text, UTF-8 is the output
2021-05-27 05:04:43 +0200 <burp> hmm well, and it works without the degree?
2021-05-27 05:05:00 +0200 <jrgiacone> no if I remove the degree it gets mad at the , sepChar
2021-05-27 05:05:12 +0200 <burp> ah, so let's fix that first
2021-05-27 05:06:07 +0200 <jrgiacone> Uploaded file: https://uploads.kiwiirc.com/files/9744170f64a60ec956074c5a465c1624/2021-05-26-200556_875x547_scrot…
2021-05-27 05:06:26 +0200 <jrgiacone> there are no tabs but with degree removed it says unexpected "s" where , sepChar is
2021-05-27 05:06:47 +0200 <burp> yea it *looks* fine, I remember I had such issues too
2021-05-27 05:07:23 +0200 <jrgiacone> lmfao
2021-05-27 05:07:46 +0200 <burp> you found it?
2021-05-27 05:07:48 +0200 <jrgiacone> do you remember what it did not like
2021-05-27 05:07:52 +0200 <jrgiacone> no lol
2021-05-27 05:08:32 +0200 <burp> Idk, try my config https://paste.tomsmeding.com/T1U0Mj1f
2021-05-27 05:09:52 +0200 <burp> just to see if it starts at all
2021-05-27 05:10:06 +0200 <a6a45081-2b83> I have this in my config `, sepChar = "%"`
2021-05-27 05:10:41 +0200 <a6a45081-2b83> can you show the exact error after running xmobar from terminal
2021-05-27 05:10:46 +0200 <a6a45081-2b83> i.e. stdout/stderr
2021-05-27 05:11:35 +0200 <a6a45081-2b83> e.g. `xmobar ~/.config/xmobar/xmobarc1234`
2021-05-27 05:13:23 +0200 <jrgiacone> Uploaded file: https://uploads.kiwiirc.com/files/f4a31427265a9b8cfb6234c1f97f48d0/2021-05-26-201312_521x122_scrot…
2021-05-27 05:13:42 +0200 <jrgiacone> burp i get font issues with those dots or something lol but it did not like them for whatever reason
2021-05-27 05:14:16 +0200 <burp> other thing I could imagine is that you launch an xmonad from somewhere without utf8
2021-05-27 05:14:37 +0200 <jrgiacone> what do you mean
2021-05-27 05:14:52 +0200 <burp> like, a global installation /usr/bin, and one in $HOME/.local/bin/xmobar
2021-05-27 05:15:04 +0200 <burp> but even the archlinux distro one should be with utf8
2021-05-27 05:15:19 +0200 <jrgiacone> oh I'm launching from .xmobarrc though?
2021-05-27 05:15:33 +0200 <burp> yea, that should be fine
2021-05-27 05:16:28 +0200 <a6a45081-2b83> try removing sep char line
2021-05-27 05:16:45 +0200 <jrgiacone> then it errors to the line below
2021-05-27 05:16:47 +0200 <a6a45081-2b83> anyways % is default value
2021-05-27 05:16:59 +0200 <jrgiacone> a instead of s
2021-05-27 05:17:09 +0200 <a6a45081-2b83> remove that too, it's also the default value :))
2021-05-27 05:17:23 +0200 <jrgiacone> then it errors to t for template expecting run lol
2021-05-27 05:17:23 +0200abhixec(~abhixec@c-67-169-139-16.hsd1.ca.comcast.net) (Quit: leaving)
2021-05-27 05:17:34 +0200 <jrgiacone> when that is gone, it no longer can run
2021-05-27 05:18:04 +0200 <a6a45081-2b83> :))
2021-05-27 05:18:21 +0200 <jrgiacone> burp what font do you have to make those dots in your templatge
2021-05-27 05:18:42 +0200 <burp> the one I specified in the xmobar config
2021-05-27 05:18:43 +0200 <burp> what about something minimal, like
2021-05-27 05:18:47 +0200 <burp> Config {
2021-05-27 05:18:47 +0200 <burp> font = "xft:Source Sans Pro:Semibold:size=8:antialias=true:hinting=true"
2021-05-27 05:18:47 +0200 <burp> }
2021-05-27 05:19:10 +0200 <jrgiacone> what is funny is my main xmonad and xmobar from arch repo's on .15 which im chatting with yall on has no issues, its only these git ones
2021-05-27 05:19:19 +0200 <jrgiacone> i have that customized to shit
2021-05-27 05:19:27 +0200 <burp> eh, I see
2021-05-27 05:20:07 +0200 <a6a45081-2b83> found the issue: https://bbs.archlinux.org/viewtopic.php?id=185573
2021-05-27 05:20:23 +0200 <jrgiacone> burp simple runs
2021-05-27 05:20:40 +0200 <burp> ah, so it's just crappy error messages :D
2021-05-27 05:20:50 +0200 <jrgiacone> let me try with mpd flag
2021-05-27 05:21:05 +0200 <burp> nah, not necessary
2021-05-27 05:21:18 +0200 <burp> I think it's because you use a module that's not compiled in
2021-05-27 05:21:31 +0200 <jrgiacone> wdym?
2021-05-27 05:21:35 +0200 <burp> jrgiacone: eh, you have alsa in your config
2021-05-27 05:21:43 +0200 <jrgiacone> i got rid of alsa
2021-05-27 05:21:46 +0200 <jrgiacone> with the flag remember
2021-05-27 05:21:53 +0200 <burp> I mean the xmobar config
2021-05-27 05:21:54 +0200 <jrgiacone> or setting it to false
2021-05-27 05:22:01 +0200 <jrgiacone> oooh